x
x
x
X
X
X
Got Android ?
Never worry about losing it again with GCloud Backup (Why should i worry?)
Get it now (Free)
X
Contact Sales
+1 (202) 697-9168
11:00 AM – 7:00 PM EST
Skip Navigation LinksHomepage Support Knowledge Base

Connect to old backup job in Genie Timeline

SYMPTOMS:
Genie Timeline supports running only one continuous backup job to one location, users often encounter problems that may force them to uninstall and reinstall Timeline or move to a different machine, this will result in Timeline dropping the backup job configuration and starting a new job.

 
CAUSE:
Uninstalling Genie Timeline and install it again or move to a new machine.

 
RESOLUTION:
This article will explain in detail a workaround that reroutes Timeline back to the original backup without having to start a new one.

Note: These instructions are a bit advanced and may be hard to follow so please contact the Technical Support Team at Genie9 if you encounter any problem.

1. Migrate the database and restore it to its original location:

Timeline keeps all the information about your backed up files and folders in a Database that is available on your backup destination in the “_GenieTimeline” backup folder, so you will need to rebuild that database by doing the following:

I. In your Windows Start menu go to:
All programs -> Genie9 -> Genie Timeline Tools -> Genie Timeline Restore.
The Timeline Advanced Restore wizard will open and give you an option in the bottom right corner to “restore from an older backup”.



II. Click the button and Browse to your (_GenieTimeline) folder that represents your backup job which you want to connect to it (Do not go any deeper into the folder structure).



III. Timeline then should start re-building the database and will show the following screen (it might pass very quickly if the database is small).



IV. When Timeline finishes building the database, close this window without restoring anything.

2. Create a dummy backup job:
I. Start Timeline (from start menu -> All programs -> Genie9 -> Genie Timeline).

II. Configure a dummy job that backs up anything (any data selection) to the same drive that contains the previous backup (the one you want to connect to it), this jobs purpose is to only configure some necessary files that are deleted at uninstall or when you move to a new machine.

III. Once the backup starts, pause it.

3. Stop Genie Timeline Service:

I. From start menu -> Search/run -> Type “services.msc” -> A List of services will appear -> Refer to “Genie Timeline Service” -> Stop.

4. Copy the built database (built from step 1) from the backup destination to your Application Data folder:

I. Go to your (_Genie Timeline) folder located on your backup destination, and browse to the database you have just built from step 1.



II. Copy the database and then paste it into your Genie’s application data folder.

You can open your Genie’s application data folder by copying the following path into your Windows explorer address bar:

• If you are using GTL 2.1:
%APPDATA%\Genie-Soft\GenieTimeLine\Jobs\{F4298088-7F22-4808-98AC-50A36B17C7A9}\Data
• If you are using GTL 2012 or 2013:
%APPDATA%\Genie9\GenieTimeLine\Jobs\{F4298088-7F22-4808-98AC-50A36B17C7A9}\Data

III. Once copied there, delete the Index.db file already in that location. Then rename the database you have just copied over to index.db



5. Change the configuration back to the old location:

I. Copy the following path and paste it into your Windows explorer address bar:

• If you are using GTL 2.1:
%APPDATA%\Genie-Soft\GenieTimeLine\Jobs\{F4298088-7F22-4808-98AC-50A36B17C7A9}
• If you are using GTL 2012 or 2013:
%APPDATA%\Genie9\GenieTimeLine\Jobs\{F4298088-7F22-4808-98AC-50A36B17C7A9}

II. Right-click the file configurations.xml and select edit.



III. Once opened for editing, refer to the “Path” line and type in the path of the old backup job that you want to connect to in the highlighted space.



6. Restart Genie Timeline Service:

I. From start menu -> Search/run -> Type “services.msc” -> A List of services will appear -> Refer to “Genie Timeline Service” -> Start.

7. Modify your data selections:

I. Open Genie Timeline dashboard -> Manage Backup -> Modify Data Selections -> Select the data that was included in the original backup because restoring the database won’t show the selections in the GUI.

APPLIES TO:
Genie Timeline (2.1, 2012 and 2013) Pro, Home and Server

   
Provide feedback on this information
     
Was this information relevant? ... ...
 
What can we do to improve this information?
 
If you were not able to find the information you were looking for, or you need assistance with a Genie9 product, please contact Genie9 Support.